It is currently Wed Oct 18, 2017 9:44 pm


2006 197 SF- no dash switches working

Electronics, projects, motors, drives, props, drill some holes, etc.
  • Author
  • Message
Offline

conor

Newbie

  • Posts: 2
  • Joined: Thu Dec 29, 2016 1:33 am
  • nospam: no

2006 197 SF- no dash switches working

PostThu Dec 29, 2016 1:44 am

Hello, I am a new user and Pioneer owner, stationed in Hawaii. Glad to have found the site.
All my factory dash switches (live well, nav lights, etc) are not working. Because its all, I am hoping it is a simple power supply issue, but havent found a smoking gun.
Absent a true bus board, does anyone know of any fuses or places I should start? I am eyeing the "Shortstop" switch but not sure if that is an actual fuse. Any pointers would be appreciated.
Offline

conor

Newbie

  • Posts: 2
  • Joined: Thu Dec 29, 2016 1:33 am
  • nospam: no

Re: 2006 197 SF- no dash switches working

PostSat Dec 31, 2016 4:19 am

Problem solved. The short stop breaker was the issue. Once the rubber boot was removed, the impressive corrosion was evident. I needed to buy additional tools and cut the wire in one side to remove it. Luckily my loca shop had one and sure enough, panel is functional.
Offline

Blue Dog

Intermediate member

  • Posts: 63
  • Joined: Mon Feb 02, 2009 8:17 pm
  • nospam: no

Re: 2006 197 SF- no dash switches working

PostMon Jan 02, 2017 9:38 am

:thumbup: The short stop fuse is the best place to start the diagnosis. Glad it worked out.
2005 Fighting Lady Yellow 197 Sportfish 150 Optimax

Return to Technical Discussion, Fix it, improvements

Who is online

Users browsing this forum: Bing [Bot] and 2 guests