It is currently Mon Jul 24, 2017 10:34 am


Mercury Fourstroke 90 Command Thrust

Electronics, projects, motors, drives, props, drill some holes, etc.
  • Author
  • Message
Offline

dave

Newbie

  • Posts: 16
  • Joined: Sat Feb 02, 2008 9:29 am
  • Location: 38-36N 77-17W
  • nospam: no

Mercury Fourstroke 90 Command Thrust

PostMon Nov 21, 2016 9:35 pm

Anyone running a new Merc Fourstroke 90 CT on their BaySport 175? I repowered from a 2004 Merc 90 Saltwater - so far, so good. Excellent performance, once ya get the thing started. Running a 14 1/2 x 19 3-blade SS prop and getting 33+ kts at 5200 RPM.
Offline
User avatar

Pungoknk

Advanced member

  • Posts: 130
  • Joined: Sat Aug 24, 2013 1:15 pm
  • Location: BELHAVEN NC
  • nospam: no

Re: Mercury Fourstroke 90 Command Thrust

PostTue Nov 22, 2016 11:45 am

With EFI, starting should not be an issue! Should start first time every time (for the most part)
Have a great day!
Image
2015 Velocity 220 Bay w/250 Mercury Verado Pro
2014 Cape Island w/150 Yamaha (Sold)
Offline

dave

Newbie

  • Posts: 16
  • Joined: Sat Feb 02, 2008 9:29 am
  • Location: 38-36N 77-17W
  • nospam: no

Re: Mercury Fourstroke 90 Command Thrust

PostSat Nov 26, 2016 3:13 pm

Turns out, my starting problem is battery related. Had a back and forth with the dealer that performed the re-power, they didn't necessarily execute the most efficient cable run from the engine to the battery located in the center console. As a result, the battery has to be fully charged to 12 volts to start. Went out yesterday with a battery pack just in case. Cranked right up! Wonderful way to escape black Friday.

Return to Technical Discussion, Fix it, improvements

Who is online

Users browsing this forum: No registered users and 2 guests