It is currently Mon Sep 25, 2017 2:57 pm


No elcetrinics work on 2006 197 venture

Electronics, projects, motors, drives, props, drill some holes, etc.
  • Author
  • Message
Offline

Tally197

Newbie

  • Posts: 4
  • Joined: Mon Jun 13, 2016 10:38 pm
  • nospam: no

No elcetrinics work on 2006 197 venture

PostMon Oct 17, 2016 9:25 pm

Have recently had some problems with my auxiliary electronics going on and off and the other day while about 15 miles out in unfamiliar waters all of my equipment like gps, nav/floor lights and stereo went out and have not worked since then. I would greatly appreciate any advice as to what i should do to rectify this problem
Offline

Dave E.

Newbie

  • Posts: 49
  • Joined: Sat Jan 31, 2015 12:18 pm
  • Location: Pawleys Island, SC
  • nospam: no

Re: No elcetrinics work on 2006 197 venture

PostSun Oct 23, 2016 2:44 pm

My electronics are hooked up to the auxiliary switches and did not work. Also my nav lights did not work. Bad switches from the factory.
Offline

kaner747

Advanced member

  • Posts: 125
  • Joined: Fri Jun 15, 2007 2:12 pm
  • Location: Groton, CT

Re: No elcetrinics work on 2006 197 venture

PostSun Oct 30, 2016 9:29 am

Sounds like a power problem. My boat had a bunch of pigtails coming off that acc switch which lead to problems. I ended up adding a new bus bar with fuses. My suggestion would be to get a multimeter and follow the circuit and clean up the birds nest the best you can by adding a bus bar.
Offline

Blue Dog

Intermediate member

  • Posts: 63
  • Joined: Mon Feb 02, 2009 8:17 pm
  • nospam: no

Re: No elcetrinics work on 2006 197 venture

PostWed Nov 23, 2016 1:07 pm

Good advice from the guys above.

I would look two more places.

Under the 'drivers" seat near the battery switch on my S/F is a short stop fuse. (don't know where it is on the venture) check it out and clean the connections. This has been a problem on several early Pioneer models. Check the link for a picture.

http://www.iboats.com/SeaDog-Resettable ... w_id.39690

Also the main wiring harness has a big multi pin connector located somewhere under the dash. I would disconnect and inspect the inside. The main power to the dash panel is part of this connection. Following the wiring as mentioned above will lead you to this connection point.

I also added a pos and neg bus bar and replaced the entire dash panel with a piece of starboard and a blue sea switch panel. Basically rewiring everything on the console side of the multi pin connector.

good luck and let us know what you find.
2005 Fighting Lady Yellow 197 Sportfish 150 Optimax
Offline
User avatar

Rbeguelin

Intermediate member

  • Posts: 60
  • Joined: Sun May 22, 2011 2:03 pm
  • Location: Bethesda, MD and Block Island RI
  • nospam: no

Re: No elcetrinics work on 2006 197 venture

PostSat Dec 03, 2016 8:02 pm

Hi Blue Dog,

I have a 2007 197 SF. She's great but the electricals are showing their age. I coated the connections awhile back in dilectic grease but...I think its time I start thinking about a new panel. Why did you choose Blue Sea panels and which one? Did you look at any other panels. Finally, did you replace the wiring as well? Replacing the wiring looks to be quite a project- is it?
I have added a white/red led light strip under the Ttop, and underwater lights off the transom with their own rocker switches...so I could easily use 8 switches.
Finally, my running and courtesy lights are analog...wondering if anyone has switched them over to led ...does Pioneer offer a retro kit? or new panels?
thanks
rob
Offline

Blue Dog

Intermediate member

  • Posts: 63
  • Joined: Mon Feb 02, 2009 8:17 pm
  • nospam: no

Re: No elcetrinics work on 2006 197 venture

PostMon Dec 05, 2016 9:02 am

Rob,

I used an 8 switch blue sea panel. It runs horizontally along the bottom of the dash panel cut out.
Blue sea makes good stuff and I didn't want to have to re do the project in 5 years.

I looked at several options but the 8 panel was best for my needs because
1 - it fit within the existing dimensions of the panel cut out.
2 - it offered two more switches. all my electronics were "piggy backed" off a single ACC switch. Now I have the GPS isolated and the VHF and stereo on another switch. I have an unused switch for now also.

I ran new wire from the panel to a bus bar mounted inside the console. I isolated the wires coming out of the existing harness and ran them to the corresponding connections on the bus bar.

I have a LED anchor light that needs installing. The mounting holes don't line up with the old analog one. There is a lot of info on retro fitting an LED nav light on your S/F. Last i looked there is not a direct replacement fixture and you have to be careful to not lose the wiring to the old fixture when disconnecting.

Image
2005 Fighting Lady Yellow 197 Sportfish 150 Optimax
Offline
User avatar

Rbeguelin

Intermediate member

  • Posts: 60
  • Joined: Sun May 22, 2011 2:03 pm
  • Location: Bethesda, MD and Block Island RI
  • nospam: no

Re: No elcetrinics work on 2006 197 venture

PostTue Dec 06, 2016 10:02 am

Thanks Blue Dog,
Nice installation...I am planning mine now for a Spring installation.
Thanks

Return to Technical Discussion, Fix it, improvements

Who is online

Users browsing this forum: Bing [Bot] and 1 guest

cron